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mal ein Token pro Stelle zugelassen. Durch
Schalten der Transitionen produce, deliver,
remove und consume ändern sich die
Zustände anhand der Pfeile zwischen den

In dem Artikel wird die Generierung eines einfachen baumbasierten Eclipse Editor-Plug-
Ins anhand eines Editors für Petrinetze mit dem „Eclipse Modeling Framework” (EMF)
beschrieben. Aufbauend auf den generierten Modellcode wird die Implementierung eines
zweiten komplexeren grafischen Editor-Plug-Ins mit dem „Graphical Editor Framework”
(GEF) erläutert.
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d i e  a u t o re n

nur eine hervorragende Programmier-
umgebung für Java (vgl. [Sun]), sondern
darüber hinaus auch eine Anwendungs-
umgebung angeboten wird, die die
entwickelten Programme mittels Plug-In-
Technologie integriert. Wesentlich unter-
stützt wird die Programmierarbeit durch
zahlreiche Frameworks und Plug-Ins. Im
Vordergrund steht hierbei die grafische
Programmentwicklung. Im Folgenden wird
die prinzipielle Arbeitsweise mit EMF und
GEF gezeigt, indem ein einfaches grafisches
Editor-Plug-In für Petrinetze in Eclipse
erstellt wird.

Petrinetze
Für einen einfachen Editor eignen sich
Petrinetze (vgl. [Rei98]), die in der In-
formatik weit verbreitet sind, um neben-
läufige Prozesse zu beschreiben. Die Stellen
eines Petrinetzes modellieren passive
Systemteile, während die Transitionen ein-
zelne Prozessaktionen modellieren.
Abbildung 1 zeigt als Beispiel für ein
Petrinetz ein Produzenten/Verbraucher-
System. Auf den Stellen ready to produce,
buffer empty und ready to remove befinden
sich Token, die aktuelle Zustände markie-
ren. In Bedingungs/Ereignis-Netzen, einer
speziellen Petrinetzvariante, ist nur maxi-

Das Eclipse Modeling Framework (EMF)
und das Graphical Editor Framework
(GEF) bieten die Möglichkeit, in kurzer
Zeit ein grafisches Editor-Plug-In zu erstel-
len, das auf einem formalen Modell beruht.
EMF unterstützt hierbei die automatische
Java-Codegenerierung des Editor-Modells
aus einem EMF-Klassendiagramm. Mit
GEF wird der Modellcode in das grafische
Editor-Plug-In integriert, das direkt in der
„Eclipse Runtime-Workbench” ausgeführt
werden kann. Hierbei stellt GEF eine Reihe
von Standardoperationen für grafische
Editoren bereit, z. B. eine Editorpalette,
Zooming und Funktionalität zum Rück-
gängigmachen/Wiederherstellen von Edi-
tieroperationen.

Die Programmierung eines grafischen
Editors allein auf der Basis von Java-Swing
oder SWT ist eine mühevolle und aufwän-
dige Arbeit. Hinzu kommt, dass das grafi-
sche Layout und die Benutzerführung in
unterschiedlichen grafischen Anwendungen
sehr stark variieren können, was den
Benutzer lange Einarbeitungszeit kostet
und unter anderem zu Problemen beim
Datenaustausch mit anderen Anwen-
dungen führt.

Alle diese Probleme sind in Eclipse (vgl.
[Ecl]) gelöst, in dem dem Entwickler nicht

Abb. 1: Petrinetz eines Produzenten/Verbraucher-Systems
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Stellen und Transitionen. Beispielsweise
bewirkt das Schalten der Transition produ-
ce, dass das Token von der Stelle ready to
produce verschwindet und ein Token an der
Stelle ready to deliver erscheint.

Editormodell
Da ein grafisches Editor-Plug-In mit GEF
nach der Model/View/Controller-Archi-
tektur aufgebaut ist, wird zunächst ein
Editormodell mit dem EMF (vgl. [EMF])
erstellt, das die grafischen Objekte im
Editor verwaltet und in einem auf XML
(vgl. [XML]) basierenden Format abspei-
chert. Hierzu muss keine Zeile Java-Code
selbst geschrieben werden. Mit dem UML-
Plug-In „OMONDO” (vgl. [Omo]) ist ein
kommerzielles, in der Grundversion
kostenloses Eclipse-Plug-In verfügbar, mit
dem sich leicht Klassendiagramme grafisch
erstellen lassen, welche die Grundlage für
das Editor-Modell sind. OMONDO ist sei-
nerseits selbst ein grafisches Editor-Plug-In
für Eclipse auf Basis von EMF und GEF,
allerdings auf einem sehr viel komplexeren
Niveau als das in diesem Artikel vorgestell-
te Petrinetzeditor-Plug-In.

Für das Petrinetzeditor-Modell wird mit
dem EMF-Klassendiagramm eine spezielle
Art von Klassendiagramm benötigt, das
eine abgespeckte Version eines UML-
Klassendiagramms (vgl. [OMG]) darstellt.
Ein wesentlicher Unterschied besteht darin,

dass Attributtypen mit einem E beginnen. So
heißt z. B. der Datentyp String unter EMF
EString und Int heißt unter EMF EInt.

Um das EMF-Modell zu erstellen, muss
in einem neuen Eclipse-Projekt ein EMF-
Klassendiagramm unter „File > New >
Other > EMF Diagrams > EMF Class
Diagram” erstellt werden. Falls der
Menüpunkt nicht verfügbar ist, ist das
OMONDO-UML-Plug-In nicht richtig
installiert. Die grafische Modellierung
gestaltet sich sehr einfach. Abbildung 2
zeigt das fertige EMF-Modell für den
Petrinetzeditor.

Wichtig ist die Basisklasse PetriNet, die
die Klassen des Petrinetzes enthält und spä-
ter bei der Instanziierung des baumbasier-
ten Petrieditors angegeben werden muss.
Bei der Modellierung ist zu beachten, dass
sämtliche Klassen direkt oder über andere
Klassen indirekt über Aggregationen
(schwarze Raute) mit der Basisklasse
PetriNet verbunden sind – nur so werden die
weiteren Klassen später im Modell abge-
speichert. Die Stellen und Transitionen
werden durch die Klassen Place und
Transition modelliert. Die Klassen ArcPT und
ArcTP repräsentieren die Pfeile zwischen
ihnen. Stellen und Transitionen haben
dabei Namen (name) und eine Position im
grafischen Editor, die durch die Attribute x
und y modelliert wird. Stellen können
zusätzlich noch Token besitzen, wobei in

diesem Fall durch das boolesche Attribut
token nur maximal ein Token zugelassen
wird, d. h. das Petrinetz wird als Bedin-
gungs/Ereignis-Netz modelliert.

Modellgenerierung
Die Generierung des Modellcodes gestaltet
sich durch EMF denkbar einfach. Im
OMONDO-Plug-In gibt es im Kontext-
menü (rechte Maustaste im Editorfenster)
vier Menüpunkte zur Generierung von
Modellcode:

1. Generate Model Code generiert die fer-
tigen Modellklassen im aktuellen Eclip-
se-Projekt, die als Basis für das grafi-
sche Editor-Plug-In dienen.

2. Generate Edit Code generiert zusätz-
lich das Projekt „<<MeinProjektname.
Edit>>” mit Editieroperationen für
einen baumbasierten Editor.

3. Generate Editor Code generiert zusätz-
lich das Projekt „<<MeinProjektname.
Editor>>” mit einem baumbasierten
Editor, der direkt in der Eclipse
Runtime-Workbench ausgeführt wer-
den kann.

4. Generate All generiert den in den
Punkten 1-3 aufgeführten Code.

Vor der ersten Generierung muss im
Dialogfenster ein beliebiger Paketname für
das Modell und die EMF-Modell-
Basisklasse PetriNet angegeben werden. Für
das grafische Editor-Plug-In wird nur der
Menüpunkt „Generate Model Code”
benötigt. Allerdings lässt sich durch die
Menüpunkte „Generate Edit Code” und
„Generate Editor Code” bereits ein recht
primitiver, baumbasierter Editor generie-
ren, der direkt in der Eclipse-Runtime-
Workbench ausgeführt werden kann.

Die Runtime-Workbench in Eclipse lässt
sich unter „Run > Run > Runtime-
Workbench” starten. In einem neuen
Projekt („File > New > Other > Simple
Project”) wird der baumbasierte Petrinetz-
Editor durch den Wizard („File > New >
Example EMF Model Creation Wizard >
MeinPetriModel”) initialisiert. Für
„MeinPetriModel” erscheint der Name des
Modells, der vor der Generierung angege-
ben wurde. Abschließend muss im Wizard
erneut die Basisklasse PetriNet angegeben
werden. Abbildung 3 zeigt den generierten
baumbasierten Petrinetzeditor in Aktion.
Im Fenster „Properties” („Window > Show

Abb. 2: EMF-Petrinetzmodell
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View > Properties”) lassen sich die
Attribute des selektierten Objekts editieren.

GEF-basierter Petrinetzeditor
Für den GEF-basierten Petrinetzeditor ist lei-
der etwas mehr Handarbeit gefragt. Im
Unterschied zu EMF bietet das GEF (vgl.
[GEF]) keine Code-Generatorfunktionalität.
Es ist lediglich ein Framework zur
Unterstützung der Entwicklung grafischer
Editoren auf der Basis von Modellen. In
unserem Fall bildet der mit „Generate Model
Code” generierte Petrinetz-Modellcode die
Basis des grafischen Editors. Allerdings bietet
GEF eine reiche Palette von Editor-
eigenschaften wie Kopieren und Einfügen,

Rückgängigmachen, Wiederherstellen und
Zoomen. Auch das Anlegen von Menüs und
Symbolleisten und deren Verknüpfung mit
Editor-Funktionen wird durch die
Verwendung von GEF erleichtert. GEF-
Editoren können nur als Eclipse-Plug-In und
nicht eigenständig gestartet werden. Ein
Vorteil dieser Einschränkung ist das einheitli-
che, elegante, zeitgemäße Erscheinungsbild
des erstellten Editor-Plug-Ins. Abbildung 4
zeigt den GEF-basierten Petrinetzeditor mit
einem editierten Petrinetz.

Download und Installation
Der gesamte GEF-basierte Petrinetzeditor
kann unter der URL tfs.cs.tu-berlin.de/

Abb. 3: Generierter baumbasierter Petrinetzeditor

Abb. 4: GEF-basierter Petrinetzeditor

petrieditor heruntergeladen werden. Auf
der Webseite sind die Projekte
„EMFPetriEditor” (GEF-basierter
Petrinetz-Editor) und „EMFPetriModel”
(EMF-Modellcode zum „Petrinetz-Editor”)
als ZIP-Archive vorhanden. Beide entpack-
ten Archive werden unter dem Menüpunkt
„File > Import > Existing Project into
Workspace” in die Eclipse-Workspace ein-
gebunden. Anschließend kann der
Petrinetz-Editor in der Eclipse-Runtime-
Workbench („Run > Run > Runtime-
Workbench”) ausgeführt werden. Zum
Starten des Petrinetz-Editors ist kein
Wizard notwendig. Stattdessen startet sich
der Editor durch Erstellen einer neuen
Datei mit der Endung .petrinet (z.B.
my.petrinet) im Datei-Dialog („File > New >
File”). Die Datei kann in dem schon vor-
handenen Projekt für den baumbasierten
Editor erstellt werden. Entscheidend ist die
Endung .petrinet, die in der Datei
plugin.xml im Attribut extensions festgelegt
wird (siehe Listing 1). Weiterhin wird defi-
niert, dass der Petrinetzeditor als Erwei-
terung („extension point”) des Standard-
EclipsePlug-Ins org.eclipse.ui.editors
geladen wird. Die Attribute contributorClass
und class beschreiben die Schnittstellen-
klassen des Petrinetzeditor-Plug-Ins zur
Eclipse-Umgebung.

Interne Architektur von
GEF-Editoren
GEF-Editoren liegt die Model/View/
Controller-Architektur zugrunde (siehe
Abb. 5). Die Controller (so genannte
EditParts bei GEF) steuern das Zusam-
menwirken des Modells (z. B. der von EMF
generierten Klassen) mit seinen Sichten
(Views) (z. B. das Panel des grafischen
Editors). So führt beispielsweise das
Absetzen des Kommandos Delete zunächst
zu einer Änderung das Modells (das
Entfernen eines Objekts), woraufhin das
Modell eine Nachricht an den entsprechen-
den EditPart sendet, der daraufhin ein Up-
date der Darstellung des Modells im
Editorfenster initialisiert.

Üblicherweise gibt es für jede Modell-
klasse genau eine EditPart-Klasse in GEF.

Für die Entwicklung eines grafischen
Editors für Petrinetze auf der Basis des
Petrinetz-EMF-Modells werden somit
EditPart-Klassen für Stellen, Transitionen
und die Pfeile zwischen diesen benötigt.
Eine Instanz eines EditParts existiert dann
genauso lange wie die entsprechende
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Modellinstanz (also z. B., bis das Objekt im
Editor gelöscht wird).

Man unterscheidet zwischen der Klasse
GraphicalEditParts (deren Modellelemente
über ein grafisches Bild dargestellt werden)
und der Klasse ConnectionEditParts (die
Verbindungen zwischen GraphicalEditParts
repräsentieren).

GraphicalEditParts enthalten demnach
Methoden, um die entsprechenden Bilder
im Editor zu erzeugen oder zu löschen und
sie bei Modelländerungen zu aktualisieren.
ConnectionEditParts sind über Ankerpunkte
mit GraphicalEditParts verbunden. Die Inte-
gration und Verwaltung der verschiedenen
EditParts in Eclipse geschieht über den
GraphicalViewer, eine Schnittstellenklasse
von GEF.

Fazit
EMF eignet sich gut zur Generierung von
Modellen zur Entwicklung von GEF-
basierten grafischen Editoren. Das gene-
rierte EMF-Modell erspart viel Program-

mieraufwand, insbesondere was das Spei-
chern und Laden von Modellinstanzen
angeht. Allerdings kann alleine mit einem
EMF-Modell eine Diagrammsprache nicht
immer komplett beschrieben werden. So
konnte die Bedingung, dass es bei Petri-
netzen höchstens eine Kante von einer
Transition zu einer Stelle (und umgekehrt)
geben darf, nicht auf der Modellebene
beschrieben werden, sondern musste von
Hand in den Editor hineinkodiert werden.
Abhilfe bietet hierbei neuerdings die OCL-
Programm-Bibliothek (Object Constraint
Language) der Universität Kent (vgl.
[OCL]), mit der sich OCL-Bedingungen
direkt in das EMF-Metamodell integrieren
lassen. Bislang muss dieses allerdings noch
per Hand geschehen, da der EMF-
Generator OCL noch nicht unterstützt.

GEF erwies sich bei der Entwicklung des
grafischen Editors als sehr hilfreich.
Allerdings sind die zu implementierenden

Klassen sehr umfangreich, weshalb in die-
sem Artikel nur ein Überblick gegeben wer-
den konnte. Eine ausführliche Beschreibung
der Entwicklung von grafischen Editor-Plug-
Ins in Eclipse bietet ein Buch aus der IBM
Redbook-Serie, das kostenlos als PDF-Datei
erhältlich ist (vgl. [IBM]). �

Abb. 5: Model/View/Controller-
Architektur
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<plugin id="EMFPetriEditor" name="%pluginName"
version="1.0.0" provider-name="%providerName"
class="petrieditor.PetriEditorPlugin">

<extension point="org.eclipse.ui.editors">
<editor name="PetriEditor" icon="icons/sample.gif"

extensions="petrinet"
contributorClass="petrieditor.actions.

PetriEditorActionBar
Contributor" class="petrieditor.editor.PetriNetEditor"
id="petrieditor.editor.PetriNetEditor" />

</extension>
</plugin>

Listing 1: Auszug aus der plugin.xml-
Datei aus dem EMFPetriEditor-Projekt


